Incorrect Format

Jun 26, 2009 at 2:21 PM

No matter what I do, I get an error message that says "Incorrect Format" when I try to upload my spreadsheet. I have made the default view of my list match the fields in my spreadsheet exactly, and the top row of the spreadsheet contains the column names. Are there any instructions on how to use this? Seems like a very promising tool, if I can figure out how to use it.

Jun 29, 2009 at 3:30 PM

At first you must install the AccessDatabaseEngine on the Sharepoint server.

Jul 1, 2009 at 2:11 PM

Jason, If you are using a spreadsheet that is tabular and the entries start at the first row and first column, then this application should work just fine.

The columns need not be in the same order in the spreadsheet as this tool will let you map each column you wish to import from the spreadsheet to a column in the SharePoint list. The only thing you need to make sure is the field types are compatible. For example, a date field cannot take a string data from the spreadsheet.

Please try again and if you are still getting the error. Will be helpful if I know what kind of data you are using.


Jul 17, 2009 at 3:02 PM

I too, am getting the same issue (Incorrect Format)

I have a list with 2 columns, Month (single line of text) and Hits (Number).

My spreadsheet looks like ("Months" is in cell A1). The Months column is formatted as Text; the Hits column is formatted as a number with 0 decimal places.

Month Hits
2008-05 14718
2008-06 20605
2008-07 19427
2008-08 13783
2008-09 19002
2008-10 17022
2008-11 11832
2008-12 26306
2009-01 20780
2009-02 26072
2009-03 33911
2009-04 33754
2009-05 20037
2009-06 45537
2009-07 17767

Any help/advice would be appreciated. How about posting a sample spreadsheet and instructions on creating a list so we can see that it's working correctly and not some odd configuration issue?


Jul 17, 2009 at 4:16 PM

Hi Dennis,

Please check that you are using the latest version (1.1) of the tool and the ensure that the data type for the "month" column in SharePoint is text and not date type.

I have just verified running the information you provided here by importing this from a spreadhseet to a custom SP list. I used a single line text for Month and number type for Hits and had not problems importing.

Please try this and let me know how it goes and if you are still having trouble ... with more details on the SP list - column types.


Jul 17, 2009 at 5:25 PM

Just re-installed 1.1. Also, had the AccessDatabaseEngine (mentioned above) installed too.

Here are the steps I'm taking:

  1. From Site Actions, I select Create.
  2. I select Custom List.
  3. I give it a name, "Web Hits" and a description of "Web site hits" and display it in the Quick Launch.
  4. SharePoint opens a list with a column called "Title".
  5. I create a new column, name it "Month", and select "Single line of text". Description is "Data month"; set it to "No" for "Require that this column contains information"; 255 characters; Default value set to "Text"; "Add to default view" is checked. Click OK.
  6. "Title" and "Month" columns are visible.
  7. I create a new column, name it "Hits", and select "Number (1, 1.0, 100)". Description is "Web site hits"; set it to "No" for "Require that this column contains information"; Min/Max values blank; "Number of decimal places" set to "Automatic"; Default value set to "Number"; "Show as percentage" unchecked; "Add to default view" is checked. Click OK.
  8. "Title", "Month" and "Web Hits" columns are visible.
  9. Verify my spreadsheet. Cell A1 contains "Month"; cell B1 contains "Hits". Values under "Month" are set to "Text" format; values under "Hits" set to number and 0 decimal places. The spreadsheet is stored on my local workstation and named "Stats.xlsx".
  10. Select "Actions" then "Import from Spreadsheet".
  11. Browse to the file and select "Open" button in dialog box.
  12. Select "Upload" button.
  13. File name disappears and red "Incorrect Format" message appears below.

I'd be happy to email in the spreadsheet if that will help. Not trying to be a pain, but this would be a cool feature if we could get it implemented. Also, if there's a way that you could make it a scheduled event - such that I can have it import and update data from a spreadsheet on a nightly basis - that would be cool.



Jul 28, 2009 at 10:39 AM


The steps you are following are all correct. But we were not able to reproduce the problem on our end initially which took us a while to get back to you on this. After a series of tests, we found that it was a permissions issue while uploading the file but as the exception was not properly handled, was giving this misleading message. We have addressed the issue and are doing the final testing before launching it. I will update you once we make it live and I am hoping this would be mid to later this week.

Thanks for your patience.

Aug 4, 2009 at 12:39 AM

Hi, I had the same Error then i just format all the spreedsheet with text format and it works, 

Ramp: also I have a question, in my list I create a field with type people, it appears this message "Type mismatch between the columns: Usuario - Usuario at row 2", it is any way to do that?

Aug 5, 2009 at 7:18 PM

Having the same issue. How do I find out the permissions setting for uploading files on my site?




Aug 11, 2009 at 9:18 AM

The permissions issue was with temp folder that was used to save the spreadsheets during the importing process. We have fixed it as a part of the version 1.2 released on Aug 7th, 2009. This problem was surfacing only for people who did not have admin level permissions to the SharePoint web server. we have exclusively defined the permissions now and the problem should not arise again.

Please download the latest version and try the fix.

Please note that this import does not work for People and groups fields. A limitation in converting string to the object. We will see if there is a workaround on this conversion and update accordingly.


Aug 12, 2009 at 8:31 AM

Could you provide a list of data types that can appear in the sharepoint custom lists and the excel equivalents. Issues Im having are date fields and multi line text fields and drop down list values all of which give me data type conversion errors.

Dec 3, 2009 at 12:03 AM


I am experiencing this same problem of Incorrect Format and I really don't understand how to solve it. I have tried formatting the cells as text. I have tried saving as an xls or xlsx file but nothing seems to work.

I have tried running tried opening up the 'temp' directory as suggested. I have formatted all columns as text but no luck. Every time, I get the 'Incorrect Format' error. I have cut columns out and added them back but no luck.

Any suggestions on what might work would be useful.

I have a list with a lot of fields and some of them are calculated but I only want to import a few fields into the list. There are no required columns. There are some choice and some lookup columns.

The list definition is:

Project Single line of text Job Single line of text Code Single line of text Ordered Date Date and Time Amount Currency OrderCompany Single line of text CompanyOverride Single line of text Q2C Product Single line of text Product Override Single line of text Product Calculated (calculation based on other columns) Product Detail Hyperlink or Picture OrderYear Calculated (calculation based on other columns) OrderedMonth Calculated (calculation based on other columns) Category Override Choice Category Calculated (calculation based on other columns) App Eng Lookup Status Choice Tracking Number Hyperlink or Picture Forecast Date Date and Time ForecastYear Calculated (calculation based on other columns) ForecastMonth Calculated (calculation based on other columns) Forecast Calculated (calculation based on other columns) Shipped Date Date and Time ShipMonth Calculated (calculation based on other columns) ShipYear Calculated (calculation based on other columns) Completed Date Date and Time CompletedMonth Calculated (calculation based on other columns) CompletedYear Calculated (calculation based on other columns) Invoiced Date Date and Time InvoicedMonth Calculated (calculation based on other columns) InvoicedYear Calculated (calculation based on other columns) Company Calculated (calculation based on other columns) Notes Multiple lines of text PSUP Choice SW Eng Lookup Revision Single line of text Customer Lookup Address Multiple lines of text E-Mail Single line of text Phone/Fax Multiple lines of text SA Yes/No SWModule Calculated (calculation based on other columns) SWCustom Calculated (calculation based on other columns) SWNotes Multiple lines of text SWCustOrModule Calculated (calculation based on other columns) Material Currency Variable Labor Currency Base Labor Currency SCM Calculated (calculation based on other columns) MCM Calculated (calculation based on other columns) ONYX_ID Single line of text Planned Start Date and Time Planned End Date and Time %Complete Number Created By Person or Group

Modified By Person or Group

The columns I would like to import are

Project, Job, Code, Ordered Date, Amount, OrderCompany, Q2C Product, Category Override, Status, Forecast Date and SA



Dec 4, 2009 at 8:46 PM

I am having the same issue of incorrect format. I have tried every suggestion listed here and nothing has worked. I have downloaded and reinstalled v1.2 (I never had v1.1). Has anyone resolved this issue? If I can't get it working, then I will need to remove and find a different solution.



Feb 15, 2010 at 6:15 PM

Same issue, running WSS 3.0 R2 on Windows 2008 R2, sufficient access to the temp folder (checked), simple spreadsheet format with one 1 text column, no joy. 


Feb 23, 2010 at 9:41 PM

Same issue of incorrect format. Running v1.2

Mar 4, 2010 at 11:14 AM

Sorry everyone, as we were not active on the discussion group for a few weeks now. got really busy playing with SP 2010 :^) and project work. Have you guys got a chance to see the Client Object model in SP2010.  You can do wonders with that .. using Javascript, or even SilverLight to display SP list and library info. Simply saying, "I am loving it"!

Anyways, The incorrect format error is thrown when you are trying to use a SharePoint field other than strings (SharePoint reference type objects) for values in Excel. There was a small bug with Setting the permissions for a temp folder on the SharePoint server, which was earlier fixed,.. that gave the same exception (a misleading one). I will test the feature over the next 2-3 days and get a stable and well tested version out for you guys. Thanks much for all the appreciation and feedback you provided.

We promise to get a few more of our cool features ,.. available to you all to explore.
You all can look forward to receive the 64 bit compatible version and the details on what all types of fields this generic add-on feature supports shortly.

If anyone is interested in making this feature more specific to meet your application needs and need any help, please feel free to contact us. or send me a message.
This feature is built to scale to any level and we have in the recent time employed workflows and timer jobs for scheduling, to get the needed functionality.







Mar 5, 2010 at 6:17 PM

Is there any progress on this error?  I have tried all the suggestions and I am the system administrator and it doesnt worked logged in as administrator either.  It would be nice it if worked.