Can't find under Site Features

Apr 16, 2010 at 9:45 PM

Hey, I ran the installer then I went to activate the feature and its not there. I've ran a repair, and removed and reinstalled it, and its still not listed under Site Features.

 

I'm running WSS 3.0

 

Please help, this tool would be invaluable.

 

Thanks

Apr 16, 2010 at 10:06 PM
Edited Apr 16, 2010 at 10:20 PM

nevermind, now i just get this

 

System.InvalidOperationException: The 'Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine. at System.Data.OleDb.OleDbServicesWrapper.GetDataSource(OleDbConnectionString constr, DataSourceWrapper& datasrcWrapper) at System.Data.OleDb.OleDbConnectionInternal..ctor(OleDbConnectionString constr, OleDbConnection connection) at System.Data.OleDb.OleDbConnectionFactory.CreateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningObject) at System.Data.ProviderBase.DbConnectionFactory.CreateNonPooledConnection(DbConnection owningConnection, DbConnectionPoolGroup poolGroup) at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection) at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory) at System.Data.OleDb.OleDbConnection.Open() at ASP._layouts_spreadsheet_spreadsheet_aspx.GetExcelSheetNames() at ASP._layouts_spreadsheet_spreadsheet_aspx.btnUpload_Click(Object sender, EventArgs e)

when i try and upload a spreadsheet

 

I'm using the x64 version with 2007 Office System Driver installed

 

Apr 28, 2010 at 4:27 PM

Does anyone have a suggestion to fix this issue?

Coordinator
May 4, 2010 at 1:00 PM

Please try the latest version of the Office driver. It might be good if you can uninstall and reinstall the driver and feature. The new beta version of the driver works great too and you might wanna try that. Another easy way is to try this on a new instance of WSS. Working with Microsoft technologies, you probably are well aware that if not installed correctly, how hard it gets to troubleshoot or fix a problem.

The feature uploaded in codeplex has been successfully tested in x64 environment for both WSS 3.0 and MOSS. We have noticed that, in some environments, people are facing security problems mainly because of the enhanced security of the latest OS versions and has to be manually set. For people running in x86 , please use the old version of this tool.

As already mentioned, this is an effort only to help the SharePoint community who face the similar kind of problems and is not a supported product. We do take the feedback and work on improving this tool when time permits and try our best to respond to all discussions but please understand that things can really get busy at times as we have our job to do and there may be delays.

Please send a personal message if you need any immediate help and I will try helping you out in the best way I can.

Thanks.